Nuxt.jsをアップデートしたらVue packages version mismatchと言われた

  • NuxtJS

Nuxt.jsの最新版がリリースされたので、アップデートしてローカル環境を立ち上げて動作確認しようとしたら、次のエラーメッセージが出力されました。

ncu -u nuxt
npm install
npm run dev

Error:

  Vue packages version mismatch:
    - vue@2.6.11
    - vue-server-renderer@2.6.12

This may cause things to work incorrectly.
Make sure to use the same version for both.

npm updateとかを実行しても改善されなかったので困っていましたが、Issueに挙がっていたのを見つけました。🎉

Issueのコメントを参考にして、以下のコマンドを実行しました。

rm package-lock.json
rm -rf node_modules
npm install

無事、ビルドも通りエラーメッセージが出なくなりました。

この記事を共有

アバター

K.Utsunomiya
男・20代
主にWebフロントエンド技術と気になった音楽について投稿していきます。
最近ハマっていることは、クロスバイクで走ることとジムでの運動です。
詳しいプロフィール

© 2020–2021 コレ棚